Resurrection of an old PC

In the way back, I built a PC for a very specific reason. I was working on a product that had several configuration options and to effectively understand how they worked together, I needed to build various scenarios and test them. To accommodate this, I built a pretty solid PC, with a beefy (for the time, 2009) Core i7 processor, a solid ASUS motherboard (my go-to brand), and three disks. One 80GB Intel SSD “boot” drive, and 2 WD Caviar Black 7200RPM drives for storage and other purposes.

The OS was the then just launched Windows 7, and I put 6 gigs of ram in it which seemed to be enough for the era. (at the time 6 gigs of RAM seemed YUUUUUUGE)

I used the hell out of the system. It was pretty good at running VMWare Workstation, and I was often tossing 4 or 5 VM’s and testing configurations with a lot of different OS’s. It worked well, speedy, responsive, and effective.

But, as time went on, and I left that job, it’s use was reduced significantly, and when I moved away from Tucson, it pretty much was mothballed. A few weeks ago, I ran across it in our storage area. Thinking I might have a good use for it, I pulled it out and plugged it in.

Of course, the battery on the computer was dead (the one that powers the RTC and NV RAM), after replacing that, I tried to boot again. Alas, after a few seconds or through the BIOS POST, it would shut off.

Crap.

Opened the case again, and noticed that in the move(s) there was obviously at least one “drop”. One of the HD’s was misaligned (and that takes a pretty heavy jolt to accomplish), and the CPU Heatsink/fan was loose. That explains the quick power-off. Clean and reseat the heatsink unit and it is “go”.

Unfortunately, it wasn’t seeing a bootable drive. Sigh. Pulled the SSD boot drive out and checked it. It looked ok (connected to my work laptop and browsed), but it still wouldn’t boot.

I built a bootable USB stick. Alas, this computer is old enough that it isn’t bootable from a USB stick. Boo. Since I didn’t want to go back to Windows 7, and honestly, I no longer have bootable media (yeah, I know I can download an ISO and burn it to a DVD), so I figured I would use Ubuntu to check it out. An ISO is 1.5GB, plugged a drive into my work laptop, and it was pretty trivial to burn it to a DVD blank.

Yay, it boots!

Knowing that I am not going to install Windows on this, I decided to just install the latest LTS version of Ubuntu (16.0.4). The first install attempt failed. Not sure why, but a second attempt was a breeze. About an hour, and I have a base Ubuntu install.

I powered it off, and slid in the two carriers with the two 1TB drives. I expected it to be a bit of a hassle to mount the drives, but alas, the system recognized and mounted them (they are NTFS formatted).

I have a few potential uses. One is to act as a media server. It is powerful enough to transcode, and serve up to whatever device (my tivo, ipad, computers, etc). The other is to use for some experimentation with FPGA’s (I have a Mojo board, and alas, it isn’t usable on a Mac, the Xilinx tools are Windows/Linux only). Or, it would make a nice MAME system.

For now, it is humming along. I am doing a little cleanup of the data on the drives (music and media, and some old backup files). I will admit that the Ubuntu install (desktop config) is quite usable.

%d bloggers like this: